问题现象
在控制中心点击检查更新,过了下载以后到了更新过程发现进度条长时间无进展,一直卡在无进度的界面。
问题原因
103X版本的应用商店在升级时会出问题,导致卡在此界面长时间无反应。
解决方案
解决方案一
重启电脑后安装应用商店的升级包下载附件,双击安装后再更新系统。
附件:
解决方案二
步骤一
查看dpkg进程
# 查看是否有deepin-app-store的dpkg进程
ps -aux|grep dpkg
步骤二
杀进程
# 多执行几次,直到控制中心的更新取消
sudo pkill -9 dpkg
sudo pkill -9 apt
步骤三
查看系统安装包状态是否正常
dpkg -l|grep -v ii
# 执行结果出现iU、iF
sudo apt install -f
步骤四
重新安装应用商店,执行如下命令:
sudo apt reinstall deepin-app-store
注意,如果重装应用商店报错以下资源被占用的情况,如下图所示,则执行:
sudo rm -rf /var/lib/dpkg/lock-frontend
sudo rm -rf /var/lib/dpkg/lock
sudo rm -rf /var/cache/apt/archives/lock
# 重装应用商店
sudo apt reinstall deepin-app-store
# 如提示存在依赖
sudo apt install -f
步骤五
到控制中心点击系统更新,如下图所示:
©统信软件技术有限公司。访问者可将本网站提供的内容或服务用于个人学习、研究或欣赏,以及其他非商业性或非盈利性用途,但同时应遵守著作权法及其他相关法律的规定,不得侵犯本网站及相关权利人的合法权利。除此以外,将本网站任何内容或服务进行转载,须备注:该文档出自【faq.uniontech.com】统信软件知识分享平台。否则统信软件将追究相关版权责任。