应用场景
CPU架构:全架构
外设型号:HP LaserJet Pro MFP M128系列(M128fn / M128fp / M128fw)、HP LaserJet Pro MFP M126系列(M126a / M126nw)
问题现象
终端用户使用统信专业版操作系统配合惠普M126系列/M128系列打印机usb直连方式时偶尔无法正常打印文件,但是通过网络连接方式添加打印机时却可以正常打印文档。
1、USB直连方式时,发送打印任务后,打印队列会显示暂停,或者提示打印超时;
2、通过
lpinfo -v
查找不到USB协议打印机信息:3、打印管理器故障诊断界面排查问题,提示连接状态异常:
4、检查CUPS服务日志可以看到如下图的报错信息:
问题原因
经过生态中心和惠普厂商确认,惠普LaserJet Pro MFP M126和M128系列打印机存在此问题,原因是打印机固件引起的USB方式获取打印机状态有问题,且由于该型号已经停产停售,厂商侧已不维护了。
解决方案
推荐采用如下临时方案:
- 推荐使用网络连接方式添加打印机并进行打印使用;
- 如使用USB方式打印,遇到打印过程中打印机状态问题时,重启打印机,可以将上次暂停的任务打印出来。但可能每次打印都需要重启一次;
- M126系列不支持网络打印,USB打印失败时可以多尝试进行几次打印;
©统信软件技术有限公司。访问者可将本网站提供的内容或服务用于个人学习、研究或欣赏,以及其他非商业性或非盈利性用途,但同时应遵守著作权法及其他相关法律的规定,不得侵犯本网站及相关权利人的合法权利。除此以外,将本网站任何内容或服务进行转载,须备注:该文档出自【faq.uniontech.com】统信软件知识分享平台。否则统信软件将追究相关版权责任。