统信桌面专业版【云扫描提示"没有发现可用的扫描仪"】解决方案

全文导读:本文介绍云扫描时,提示"没有发现可用的扫描仪"时的解决方法。

问题现象

无法通过"中晶g 530" 扫描仪,实现云扫描,提示"没有发现可用的扫描仪",分析日志 deepin-cloud-scan.log 报错如下图 :
日志截图

问题原因

在扫描仪驱动自带的软件运行的同时使用了云扫描。

解决方案

卸载自带的扫描软件并彻底退出,再使用云扫描即可。
排查分析:
步骤一
使用中晶扫描仪自带的扫描软件 进行扫描,自带的如果不能扫描,则可能是驱动不支持或者本身有问题;
步骤二
确认扫描管理器的版本是不是5.1.4及其以上版本,如果不是,则需要单独安装扫描管理器的新版本。1030自带的扫描管理器并没有适配云扫描,所以可能调不起扫描仪。
扫描管理器版本界面
步骤三
根据服务端界面程序的日志config.log发现,应该是多个用户同时使用Twain导致冲突,或者有可能是,在扫描仪驱动自带的软件运行的同时使用云扫描。
日志截图

 ©统信软件技术有限公司。访问者可将本网站提供的内容或服务用于个人学习、研究或欣赏,以及其他非商业性或非盈利性用途,但同时应遵守著作权法及其他相关法律的规定,不得侵犯本网站及相关权利人的合法权利。除此以外,将本网站任何内容或服务进行转载,须备注:该文档出自【faq.uniontech.com】统信软件知识分享平台。否则统信软件将追究相关版权责任。

2023-02-08
3 2